DeFlicker filter problem

Support for my VirtualDub filters
Post Reply
vidjim
Posts: 5
Joined: Sun Nov 28, 2010 3:02 pm

DeFlicker filter problem

Post by vidjim » Mon Nov 29, 2010 10:29 am

Can anyone help me figure out what I am missing in trying to use the DeFlicker filter for VirtualDub. I followed instructions in attempting to remove flicker from an old 8mm video transfer. After saving/processing the file I find no difference in the pre-process vs. processed files. They look the same with no decrease in flicker.

User avatar
admin
Site Admin
Posts: 4393
Joined: Thu Sep 09, 2010 3:08 pm

Re: DeFlicker filter problem

Post by admin » Mon Nov 29, 2010 10:37 am

Post a link to an unprocessed source sample.

vidjim
Posts: 5
Joined: Sun Nov 28, 2010 3:02 pm

Re: DeFlicker filter problem

Post by vidjim » Mon Nov 29, 2010 4:17 pm

Never done that before.

User avatar
admin
Site Admin
Posts: 4393
Joined: Thu Sep 09, 2010 3:08 pm

Re: DeFlicker filter problem

Post by admin » Mon Nov 29, 2010 5:32 pm

Sorry to hear that.

vidjim
Posts: 5
Joined: Sun Nov 28, 2010 3:02 pm

Re: DeFlicker filter problem

Post by vidjim » Mon Nov 29, 2010 9:47 pm

I am attempting to deflicker 8mm film shot at 24fps and video taped at the standard 30 fps. I followed Jake Ludington's instructions (www.jakeludington.com/virtualdub/2007203_how to deflicker 8mm_movies.html) and also the "Filter How-To" at your site. The saved video still flickers the same as if the filter had zero effect.

User avatar
admin
Site Admin
Posts: 4393
Joined: Thu Sep 09, 2010 3:08 pm

Re: DeFlicker filter problem

Post by admin » Tue Nov 30, 2010 9:09 am

Please post a link to an unprocessed source sample.

There are various reasons that may cause the problem. One is that you are goofing up. Another is that the material may not be amenable to the filter because it does not have full frame flicker but rather "rolling shutter" flicker. So to help you properly, we need to see an unprocessed source sample. You can upload it to mediafire.com and post the link here.

vidjim
Posts: 5
Joined: Sun Nov 28, 2010 3:02 pm

Re: DeFlicker filter problem

Post by vidjim » Fri Dec 03, 2010 2:08 pm

Sorry for the delay. Here is the link to the video: http://www.mediafire.com/file/ye86qms8j ... %20Int.avi

Didée
Posts: 22
Joined: Wed Oct 27, 2010 2:19 pm

Re: DeFlicker filter problem

Post by Didée » Sat Dec 04, 2010 11:11 am

Oh my. Samples usually shouldnt't be 1 GigaByte in size. One or two hundred frames would've been plenty enough ...

The flicker does have some of the mentioned "rolling shutter" characteristics. Maybe that's why VD deflick doesn't work very well.

I'm not used anymore to use VirtualDub filters, since Avisynth filtering offers so much more possibilities and control. The following was quickly thrown together:

http://www.mediafire.com/?1a8vwlh3kcfc6w0 (~31 MB, Avisynth script --and-- before-after video comparison)

It's sort of a compromise. Working frame-globally without localisation, the filter effect will be poor in this case. Working with strict localisation (per-pixel temporal processing), the flicker can be eliminated completely, but it gets very difficult to avoid severe artifacting in areas with motion. I've settled for a compromise that removes a major part of the flicker, and does rather little harm to moving parts.

vidjim
Posts: 5
Joined: Sun Nov 28, 2010 3:02 pm

Re: DeFlicker filter problem

Post by vidjim » Tue Dec 07, 2010 12:53 pm

Thanks. It looks a lot better. I will try Avisynth for the rest of my old projects which run into many hours. Thanks again.

Post Reply