DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Support forum for DGAVCDecDI
doc_dvxm
Posts: 3
Joined: Fri Apr 15, 2011 3:39 am

DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by doc_dvxm » Fri Apr 15, 2011 11:35 am

Hi Donald,

Firstly I want to thank you for your hard work with all your tools.

Yesterday, I've started using your h264 indexing tool - DGAVCDecodeDI. I can say that I am very satisfied with the speed of both - DGAVCDecodeDI & DiAVC.

Also, today, after updating to 2006 (svn) version of meGUI, meGUI going to crash when I am trying to load a properly indexed with succesfully licensed & activated version of DGAVCDecodeDI & DiAVC.

Btw, I am able to load same script with AvsP fine.

My script is:
LoadPlugin("C:\Program Files (x86)\AviSynth 2.5\plugins\DGAVCDecodeDI.dll")

DGSource("S:\The ....... 2006\Sources\The.........2006.AVC.FRA.DTSHD.dgi").AssumeFPS(24000,1001)

Spline36Resize(1920, 798, 0, 140, -0, -142)
Maybe it is a bug in meGUI - it was reported to related thread at ???. But meGUI loading succesfully same file with FFMS2. Also it loaded succesfuly same file indexed with DGAVCDecode (as a .dga file)

Did you have any suggestions?

Btw, my OS is Win 7 64 Bit Ultimate Edt.

Thanx in advance...

doc

doc_dvxm
Posts: 3
Joined: Fri Apr 15, 2011 3:39 am

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by doc_dvxm » Sun Apr 17, 2011 10:31 am

Reinstalling of meGUI resolve the problem.

Sorry for inconvenience.

doc_dvxm
Posts: 3
Joined: Fri Apr 15, 2011 3:39 am

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by doc_dvxm » Tue Apr 19, 2011 1:44 am

My problem still persist. Sometime, it opens properly, but usually meGUI going to crash....

I've switched to stable server and back to 1939 (svn) but it's same... Also, it's same with 2008 (svn)...

There is no problem when I am using x264 commandline with same script....

What's wrong ???

RGB
Posts: 7
Joined: Wed May 04, 2011 3:10 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by RGB » Tue Dec 13, 2011 2:56 pm

MeGUI always crashes when I open a script that uses DGAVCDecodeDI, which is a shame, as I like using MeGUI.

Nick007
Posts: 38
Joined: Wed Sep 29, 2010 12:20 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by Nick007 » Tue Dec 13, 2011 8:12 pm

From experience of my friend, recent versions of Megui are bogus. I'm using old 0.3.4.0 with vfw4x264.exe and 64-bit x264.exe and it never ever failed on me. If the script previews in AvsPmod, then it opens in Megui 0.3.4.0 without problems. I use Megui only as frontend (queue, saved settings, log, bitrate calc) for custom avs (not because its built-in stuff) and 0.3.4.0 just works, so I haven't had any need for upgrading.

RGB
Posts: 7
Joined: Wed May 04, 2011 3:10 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by RGB » Tue Dec 13, 2011 8:32 pm

Thanks for the tip. I'll give it a try. :-)

Matrosko
Posts: 3
Joined: Thu Dec 15, 2011 7:34 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by Matrosko » Fri Dec 16, 2011 3:54 am

There is not support in megui for this tool.
If i try to load an index to crate script it gives me a popup error like this:
Image

So to load the index i must rename DGavcdecDi.dll to DGavdecNV.dll and put it on dgindexnv folder.
Also diavc.ax is in the same folder.
Doing so i can create a script but when i try to load it... megui crashes with this error:

Code: Select all

Firma problema:
  Nome evento problema:	BEX
  Nome applicazione:	megui.exe
  Versione applicazione:	1.0.2068.0
  Timestamp applicazione:	4ee68152
  Nome modulo con errori:	diavc.ax_unloaded
  Versione modulo con errori:	0.0.0.0
  Timestamp modulo con errori:	4ceec48f
  Offset eccezione:	7384c768
  Codice eccezione:	c0000005
  Dati eccezione:	00000008
  Versione SO:	6.1.7601.2.1.0.1296.17
  ID impostazioni locali:	1040
  Informazioni aggiuntive 1:	fa66
  Ulteriori informazioni 2:	fa6696398de2b9f98383d7a3bf5c3ea1
  Ulteriori informazioni 3:	d1ed
  Ulteriori informazioni 4:	d1edbcc00c19a40f9b56bb439c959571
The script is loaded fine on virtualdub.

Code: Select all

LoadPlugin("C:\Program Files (x86)\MeGUI-x86\tools\dgindexnv\DGDecodeNV.dll")
DGSource("E:\test\test.dgi",fieldop=0)
LanczosResize(624,352) # Lanczos (Sharp)
Dunno why you asking money for this thing.
Latest ffdsow runs about the same speed and it's free.
This software is not even supported by megui.
The only way to encode with x264 is by command line.
The only way to encode with xvid is using witualdub but final filesize become erroneus with same settings that gives perfect results with ffdshow, and, finally i cant use xvid_encraw via cmd because crashes too.
With xeon 8 core, from 1080p source, only 50fps vs 40fps given by ffdshow (20% more?).
And i must do everything by cmd...
Why any DG indexing tool is supported by megui and not this?
Could please send a free copy of this tool to the developer of megui to add this on his code?

thanks

User avatar
admin
Site Admin
Posts: 4052
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by admin » Fri Dec 16, 2011 9:27 am

The DI software version is documented as alpha quality. It will likely not be developed any further. If you need a refund PM me your details.

ianb
Posts: 2
Joined: Thu Sep 30, 2010 5:19 pm

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by ianb » Wed Dec 21, 2011 3:04 am

Error 0x7E is ERROR_MOD_NOT_FOUND and from a LoadLibrary() call means that another .DLL that the target .DLL has been statically linked with cannot be found.

Use a .DLL dependency printing program (e.g. dumpbin /imports) to check the list of required .DLL's.

And from the vague description above about where the op has the files, I would guess some of the various other .DLL's are not is a directory where windows looks for them any more. Micro$oft has significantly tightened the rules about where .DLL can be loaded from.

Zathor
Distinguished Member
Distinguished Member
Posts: 88
Joined: Sun Nov 28, 2010 6:06 am

Re: DGAVCDecodeDI & MeGUI 2006 (svn) Crash

Post by Zathor » Mon Jan 02, 2012 1:34 pm

neuron2 wrote:The DI software version is documented as alpha quality. It will likely not be developed any further. If you need a refund PM me your details.
Very sad to hear that. I was just going to try to add DGAVCDecDI into MeGUI. Nevertheless thank you very much for your effort!
Nick007 wrote:From experience of my friend, recent versions of Megui are bogus.
??? Please create a bug report or send me the details about the problems (here as a PM or in the ??? forum). In my opinion there are sometimes of course new problems with newer builds but in general newer versions are less buggy than old ones.
But please keep in mind that MeGUI never supported DGAVCDecDI and (as written above) never will support it.

Btw I am going to remove the old DGAVCDec (should have done that already a long time ago).

Post Reply