[RESOLVED] "Could not create DiAVC decoder !"

Support forum for DGAVCDecDI
Post Reply
ganymede
Posts: 8
Joined: Sat Oct 02, 2010 4:03 pm

[RESOLVED] "Could not create DiAVC decoder !"

Post by ganymede » Sat Oct 02, 2010 8:12 pm

Hi,

DiAVC and DGDecNV are working on my computer, but I can't get DGAVCIndexDI to work.
I can launch DGAVCIndexDI, but when I open a video file, I got an error window with title "Decoder open failure" and text "Could not create DiAVC decoder!", then the program is stopped.

I'm sure that DiAVC is correctly registered since I can use it in other apps (even in Avisynth with DirectShowSource).

I tried to run "DiAVC Registration.exe" from the DGAVCDecDI directory, without success. I also tried to copy "diavc.ax" and "diavc_mmx.ax" in this directory but it didn't solve my problem.

I'm using Vista 32 bits, DGAVCDecDI reports itself as version 2024 in Help->About dialog.

What sould I do to get DGAVCIndexDI to work ? Is there something I missed ?

Thanks in advance.

User avatar
admin
Site Admin
Posts: 3927
Joined: Thu Sep 09, 2010 3:08 pm

Re: "Could not create DiAVC decoder !"

Post by admin » Sat Oct 02, 2010 8:30 pm

That's a DiAVC error. You'll have to contact schweinsz at DiAVC about it. I believe he is aware of some issues on Vista/Win7 that he is working on.

ganymede
Posts: 8
Joined: Sat Oct 02, 2010 4:03 pm

Re: "Could not create DiAVC decoder !"

Post by ganymede » Sun Oct 03, 2010 5:44 am

Thanks.
[EDIT] Schweinz sent me a copy of DiAVC 1.2.0 trial version, which solves the problem.

Post Reply