[RESOLVED] DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Support forum for DGDecNV
Selur
Distinguished Member
Distinguished Member
Posts: 112
Joined: Mon Nov 05, 2012 4:49 pm

[RESOLVED] DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by Selur » Thu Mar 14, 2019 7:35 am

Today I updated my NVIDIA drivers and DGIndexNV, now with NVIDIA drivers 419.35:
Using 32bit DGIndexNV 2053.0.0.172 I start DGIndexNV, but when triggering File->Open (or pressing F2), DGIndexNV simply closes.
Using 64bit DGIndexNV 2053.0.0.172 I start DGIndexNV, but when triggering File->Open (or pressing F2) and opening a 10bit file, I get: "GPU decoder: Failed to create video decoder [801]. Exiting..."
Opening 8bit files works fine.
Reinstalling the NVIDIA drivers (deleting all old settings, rebooting system) didn't help.
-> any advice?

Cu Selur

User avatar
admin
Site Admin
Posts: 4341
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by admin » Thu Mar 14, 2019 8:19 am

First try a full power-down restart. If that does not work, then try a re-install of 419.17 selecting the clean re-install option. If that does not work, first use the DDU utility and then re-install of 419.17 selecting the clean re-install option. If that does not work, I don't know what to tell you. I am unable to install 419.35 on my system because the installer crashes. :(

What is your nVidia card? That 801 means that "the operation is not supported on the current device".

User avatar
admin
Site Admin
Posts: 4341
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by admin » Thu Mar 14, 2019 12:05 pm

I managed to get 419.35 installed through device manager. 10-bit streams are still working fine for me on my 2080 Ti.

Selur
Distinguished Member
Distinguished Member
Posts: 112
Joined: Mon Nov 05, 2012 4:49 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by Selur » Thu Mar 14, 2019 12:29 pm

Will try to figure out the driver problem. :/

Any idea what is causing DGIndexNV 32bit to close when calling File->Open (or File->Open Project)?
(the gpu drivers shouldn't be involved at that point)


-----
Okay, HEVC 10bit works again. Manually deleted a few additional files, reinstalled the whole drivers.
DGIndexNV 32bit closing issue is still present. :/
-> okay, after I called the file to open through the command line once, the opening dialog works again,...
Strange. :)

User avatar
admin
Site Admin
Posts: 4341
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by admin » Thu Mar 14, 2019 1:22 pm

Don't know about the 32-bit crash. Maybe it was loading an old INI file format and getting confused. When I make a new version that changes the format I advise to first delete the existing INI file before opening DGIndexNV. I don't know what version you upgraded from so can't say whether an INI file format change was involved.

Good to hear it's all working again for you.

Selur
Distinguished Member
Distinguished Member
Posts: 112
Joined: Mon Nov 05, 2012 4:49 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by Selur » Fri Mar 15, 2019 1:26 am

Yeah, you are right it seems to be loading something additionally.
When copying DGIndexNV and DGDecode.dll in a separate folder, DGIndexNV works fine.
Problem is, that when I copy those files back (+ the new DGIndexNV.ini) the problem is still there. :/
Any hint what other files could cause problems? My avisynthPlugins-folder is rather full with stuff ;) (see: https://pastebin.com/Yg3QEQPL)

Cu Selur

User avatar
admin
Site Admin
Posts: 4341
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by admin » Fri Mar 15, 2019 3:52 pm

Your current situation is not clear to me. I thought you were saying DGIndexNV 32-bit was crashing on open. So how could your plugins directory be relevant? Let's start again from scratch with no assumptions.

You open DGIndexNV 32 and it crashes immediately, is that it? Please do this: Extract the files into a directory. Copy your license file there. Make sure you have no INI file there before opening DGIndexNV 32. Now open DGIndexNV 32. Does it crash immediately? Or only after trying to open a file?

I don't know what you mean by "a separate folder" and "copy those files back".

On my system everything is working fine for 32-bit and 64-bit.

Selur
Distinguished Member
Distinguished Member
Posts: 112
Joined: Mon Nov 05, 2012 4:49 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by Selur » Fri Mar 15, 2019 4:05 pm

You misunderstood me there.
32bit DGIndexNV closes as soon as I:
a. click on File->Open
b. click File->Open Project
c. press F2
as long as DGIndexNV.exe and DGDecodeNV.dll reside inside my normal avisynthPlugins-folder.
When copying those two files into a separate folder where they are on their own, everything works. This is why I suspect this is related to some .dll that is located inside the avisynthPlugins-folder. :)
Since you mentioned the .ini file I:
a. deleted the one inside the avisynthPlugins-folder, which didn't help.
b. copied the one created in the separate folder into the avisynthPlugins-folder, which didn't help either.
-> don't think this is related to the .ini file.

Cu Selur

Ps.: just wanted to know whether you see a dll that could be the culprit, so I don't have to test them all. ;) (will do so tomorrow)

User avatar
admin
Site Admin
Posts: 4341
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by admin » Fri Mar 15, 2019 5:08 pm

You're still being a bit unclear. You give a list a,b,c. Does that mean doing any one of them crashes, or do them in sequence?

Let's assume it's any one of them. So you open DGIndexNV and then do File/Open and it immediately crashes, without you specifying a file and hitting OK? If so, something must be very wrong, as all it does is open a standard windows file open dialog box. Are you running some ancient OS like XP or something? And you never told me what nVidia card you have. Also, do you have network paths involved or is it all local to your hard disk?

In your first post you mention opening a file. So which is it? I need to know the exact sequence of steps that cause the crash. And is it only 10-bit files, etc. Can you provide any crash dumps?

I don't advise putting DGIndexNV in your plugins directory. Theoretically it should be OK but with all the crap you have in there who knows what could be happening? For example, you have what look like windows DLLs in there (e.g., api-ms-win-core-delayload-l1-1-0.dll, etc.). What the heck is that all about?

Selur
Distinguished Member
Distinguished Member
Posts: 112
Joined: Mon Nov 05, 2012 4:49 pm

Re: DGIndexNV closing,... (DG 2053.0.0.172 + NV 419.35)

Post by Selur » Fri Mar 15, 2019 5:32 pm

Does that mean doing any one of them crashes, or do them in sequence?
any one of these :)
Let's assume it's any one of them. So you open DGIndexNV and then do File/Open and it immediately crashes, without you specifying a file and hitting OK?
Yes, the open dialog doesn't appear. Program simply closes.
Are you running some ancient OS like XP or something?
Nope. Windows 10 pro 64bit, with the latest updates installed.
And you never told me what nVidia card you have.
Geforce GTX 1070 TI
Also, do you have network paths involved or is it all local to your hard disk?
All on local drives.
In your first post you mention opening a file. So which is it? I need to know the exact sequence of steps that cause the crash. And is it only 10-bit files, etc. Can you provide any crash dumps?
The problem with the 10bit files was fixed by manually deleting everything related to NVIDIA, rebooting and reinstalling. At the beginning I assumed the DGIndexNV closing issue was related to this.

What I do:
  1. extract DGDecNV.exe and DGDecodeNV.dll into 'I:\Hybrid\32bit\avisynthPlugins' (lokal SSD)
  2. Start DGDecNV.exe and then click on 'File', then I click on 'Open' and DGDecNV closes
    Uploaded a short video.
Since this doesn't happen when DGDecNV.exe and DGDecodeNV.dll are alone in a separate folder, I suspect that one of the dlls inside my avisynthPlugins folder is causing the problem.
I don't advise putting DGIndexNV in your plugins directory. Theoretically it should be OK but with all the crap you have in there who knows what could be happening?
I assumed that you should know which .dlls your compiled binary relies on and tries to load, but that doesn't seem to be the case.
-> like I wrote before, it's not really a problem I'll tomorrow test which dll is causing the problem, just hoped that you might be able to narrow down the search.
For example, you have what look like windows DLLs in there (e.g., api-ms-win-core-delayload-l1-1-0.dll, etc.). What the heck is that all about?
It's a portable avisynthPlugins-folder thus all runtime dlls need to be there. ;)
(I don't have Avisynth installed in the system,..)

Cu Selur

Post Reply