[RESOLVED] DGIndexNV batch job

Support forum for DGDecNV
Jagutherrschaften
Posts: 10
Joined: Wed Nov 03, 2010 6:04 am

Re: [RESOLVED] DGIndexNV batch job

Post by Jagutherrschaften » Tue Jan 02, 2018 4:31 pm

Thank you for your reply.

Code: Select all

@echo off
for %%m in (%*) do (
	"C:\Program Files\MeGUI\tools\dgindexnv\DGIndexNV.exe" -i %%m -od "%%~nm.dgi" -h 
	echo Indexed "%%~nxm".
)
pause
This is what I am using at the moment. If I add

Code: Select all

-a
after "%%~nm.dgi" nothing changes. Seems I don't understand how to use it :? .

gonca
Distinguished Member
Distinguished Member
Posts: 563
Joined: Sun Apr 08, 2012 6:12 pm

Re: [RESOLVED] DGIndexNV batch job

Post by gonca » Tue Jan 02, 2018 4:59 pm

Try it before -od and see if it works

Jagutherrschaften
Posts: 10
Joined: Wed Nov 03, 2010 6:04 am

Re: [RESOLVED] DGIndexNV batch job

Post by Jagutherrschaften » Tue Jan 02, 2018 5:32 pm

Same result, demuxing the video works fine, no audio file is created.

gonca
Distinguished Member
Distinguished Member
Posts: 563
Joined: Sun Apr 08, 2012 6:12 pm

Re: [RESOLVED] DGIndexNV batch job

Post by gonca » Tue Jan 02, 2018 5:40 pm

Are you using the 32 bit or 64 bit version?

Open up DGIndexNV directly and drag and drop your file into it
Enable audio demux and then save project with video demux
Does it work?

User avatar
admin
Site Admin
Posts: 3885
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] DGIndexNV batch job

Post by admin » Wed Jan 03, 2018 7:51 am

As gonca suggests, you must have Enable_Audio_Demux=1 in the INI file. You can either edit it manually or you can enable it in the DGIndexNV GUI via Audio/Enable audio processing.

For the next slipstream I will make -a automatically assume processing is enabled.

If this does not resolve your issue, can you make available a short unprocessed source sample (50MB is fine)? You can cut TS files with DGSplit, or you can open it in DGIndexNV, set a range, and then do File/Output Trimmed TS.

Jagutherrschaften
Posts: 10
Joined: Wed Nov 03, 2010 6:04 am

Re: [RESOLVED] DGIndexNV batch job

Post by Jagutherrschaften » Thu Jan 04, 2018 8:18 am

Thank you for your help :hat: .

I realized that the "Enable_Audio_Demux=1" was already in the INI-file, I additionally checked "Enable audio processing" in the GUI.
The setting wasn't there after closing and reopening the GUI. I then changed the permissions of the file DGIndexNV.ini - I gave all the different rights to all users and reapplied the settings. This solved my problem, the settings are saved and now demuxing audio and video and indexing the files works with the following batch-code:

Code: Select all

@echo off
for %%m in (%*) do (
	"C:\Program Files (x86)\MeGUI\tools\dgindexnv\DGIndexNV.exe" -i %%m -a -od "%%~nm.dgi" -h 
	echo Indexed "%%~nxm".
)
pause


This makes DGIndexNV even more valuable for me, thanks a lot :bow:

User avatar
admin
Site Admin
Posts: 3885
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] DGIndexNV batch job

Post by admin » Thu Jan 04, 2018 8:41 am

Good to hear you have it sorted out and thank you for the status update.

Post Reply