[RESOLVED] DGindexNV started crashing.

Support forum for DGDecNV
renols
Posts: 25
Joined: Tue Feb 22, 2011 3:34 am

[RESOLVED] DGindexNV started crashing.

Post by renols » Tue Jul 10, 2018 3:50 pm

Hi.

I wanted to demux a 4k UHD today. I have done that previously without any problems.

In all cases I am opening the mpls file.

I started out with build 152, and it crashes when it gets to the end of the demuxing. I end up with a folder that looks like it might be complete files, but since dgindexnv crashes I have no way of knowing if the files are complete. The dgi file is 0 byte. Also there is no log file created. In the Demux menu all the PGS subs are shown and they are also demuxed. But don't know if they are complete.

With build 150 I just end up with a 0 byte dgi file and nothing else. Also here it crashes when one thinks the demux is done. No subtitles are shown in the demux menu.

With build 149 the demux crashes right at the end. 0 byte dgi file, no log file. But all other files looks like they could be complete. No subtitles are shown in the demux menu. I find that kinda weird, as I think the subs stuff was added at this point. There is a forced subtitles only checkbox, but no subs shown.

With build 147 the demux completes successfully with a complete dgi file and all. There are no subtitles shown in the demux menu, so only audio files and the dgi file are created.

I am running Windows 7 Ultimate. GTX960 GFX and the driver version is 398.11.

I have used 64bit dgindexnv in all the above tests.

I thought it was due to the addition of subtitle demuxing. But since build 149 and 150 also doesn't Work, I guess thats not it. Those don't show any subs in the demux Windows though. Only build 152 does that.

Any idea what could go wrong?

I see no difference in memory useage, and I also don't see any change in GFX memory useage when comparing 147 vs 152.

I could try a normal bluray and see if it works there, but there shouldn't be any difference or?

Maybe it is just me doing something wrong. But its pretty simple. Open mpls file, check demux menu and press F4 to demux.

Let me know if you need any more information please.

Thanks in advance.

renols



I just tried to demux a "normal" bluray with build 152, and it completed just fine. With subs and all. Not sure what goes wrong then.

Tried another "normal" bluray. Build 152 crashes right at the start of the demux. Build 147 completes the demux fine.

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Tue Jul 10, 2018 4:57 pm

If you point me to a standard bluray that does it I can buy it and try to reproduce the issue.

I'll read your post more carefully later tonight to see if there are any clues.

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Tue Jul 10, 2018 9:24 pm

OK, please do some debugging for me. First, let's use build 152 and the normal bluray that crashes. Also please tell me the title and region so I can buy it.

Run that project with nothing demuxed. Does it crash? Then add things back to demux one-by-one until it crashes, and tell me which thing caused it to crash.

Thanks.

renols
Posts: 25
Joined: Tue Feb 22, 2011 3:34 am

Re: DGindexNV started crashing.

Post by renols » Wed Jul 11, 2018 2:44 am

The disks I have available are all non US disks. They are Scandinavian disks. Buying one might therefore be an issue.

However I have done some more testing, and I "might" have found something.

Build 147 seems to demux no matter what mpls file I throw at it.

Build 152 seems to crash if there is more than one m2ts file in the mpls. It seems to demux the first m2ts, but then crash when it should change to the Next m2ts file in the mpls.

I have tried to demux just one of the m2ts files from the mpls directly by opening the m2ts file in build 152. This gets demuxed fine with subs and everything.

If there is only one m2ts file in the mpls, then build 152 also demuxes fine.

I don't know if this is the answer, but from I can see in my tests it could be the problem.

Even if I disable demuxing build 152 still crashes with a 0 byte dgi file when I load a mpls file with more than one m2ts file in it.

Sorry about the long and cumbersome explanation in my first post. Was just trying to make it is detailed as possible :-)

renols

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Wed Jul 11, 2018 6:07 am

Great data there renols. I'll try to duplicate that.

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Wed Jul 11, 2018 8:01 am

Duplicated. Something's wrong with the MPLS parser. Investigating...

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Wed Jul 11, 2018 8:14 am

I found the problem...one little misplaced } in the parser. :P

Please test this fix. If it is OK I will make a slipstream.

http://rationalqm.us/misc/DGIndexNV_renols.exe

renols
Posts: 25
Joined: Tue Feb 22, 2011 3:34 am

Re: DGindexNV started crashing.

Post by renols » Wed Jul 11, 2018 9:58 am

I can confirm that the test version successfully demuxes. I end up with the same sized files as with build 147 plus all the subtitles.

However I may have found another issue.

There is an insane amount of subs on the disk I am testing with.

If I open the mpls file and then press F4 to demux, then all Works fine and I end up with all the files demuxed.

If I open the mpls file end enter the demux menu and press done dgindexnv crashes.

If I open the mpls file and enter the demux menu and deselect subs after 12bc and press done, it will exit the demux menu just fine. Haven't tried to demux, as it takes me 15 minutes each time I want to test a demux.

As soon as I enable the 12bd subs in the demux menu and press done dgindexnv will crash.

I don't know if it has to do with the numer of subs, or what exactly happens. I tried to enable all the subs and then disable the first 6 subs. Then I can press done and exit the demux menu just fine. Seems like if I select more than 29 subs I am not able to exit the demux menu without dgindexnv crashing. Selecting 12a0 to 12bc works. Selecting 12a0 to 12bd brings a crash when done button is clicked.

renols

User avatar
admin
Site Admin
Posts: 3922
Joined: Thu Sep 09, 2010 3:08 pm

Re: DGindexNV started crashing.

Post by admin » Wed Jul 11, 2018 10:19 am

How many total items are listed in the demux dialog (checked or unchecked total)?

renols
Posts: 25
Joined: Tue Feb 22, 2011 3:34 am

Re: DGindexNV started crashing.

Post by renols » Wed Jul 11, 2018 10:35 am

The total is 12a0 through 12bf which should be a total of 32 subtitles.

It is only if I enter the demux menu and press done that it happens if too many are enabled.

If I just leave the demux menu alone everything gets demuxed (all 32 subs).

It must be something that happens when clicking done and exiting the demux menu.

I know it is a crazy lot, and most disks don't have that amount of subtitles.

renols

Post Reply