[RESOLVED] EAC-3 7.1 in m2ts

Support forum for DGDecNV
User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: E-AC3 7.1 in m2ts

Post by admin » Tue Feb 26, 2019 1:35 pm

Let's consider tormento's additional feature request after we get the EAC3 detection fixed. Thanks DJATOM for your information about it.

Here is a 64-bit test version of DGIndexNV for the EAC3 detection fix. There may be a case where you get a popup asking to send me the stream. It covers a case that is unclear (to me) in the spec. Thank you for your testing.

http://rationalqm.us/misc/DGIndexNV_tormento.exe

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: E-AC3 7.1 in m2ts

Post by admin » Tue Feb 26, 2019 7:03 pm

I discovered by looking for samples online that it does not work for EAC3 without AC3 core, such as in a DVB transport stream or HD-DVD. I am working on that. Works for me with bluray m2ts.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: E-AC3 7.1 in m2ts

Post by admin » Wed Feb 27, 2019 10:55 am

Please re-download as I have added proper support for streams without an AC3 core. I also removed the popup and added proper code for the unclear case I mentioned earlier. Hopefully, this build is now good to go.

http://rationalqm.us/misc/DGIndexNV_tormento.exe

Thank you for your testing.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: E-AC3 7.1 in m2ts

Post by admin » Thu Feb 28, 2019 11:59 am

Well, I'm feeling pretty confident about the changes as they are working fine on all the test files I have been able to find. I'll slipstream later today unless I hear from y'all of any test failures in the meantime.

User avatar
tormento
Distinguished Member
Distinguished Member
Posts: 202
Joined: Mon Sep 20, 2010 2:18 pm

Re: E-AC3 7.1 in m2ts

Post by tormento » Mon Mar 04, 2019 4:08 am

admin wrote:
Thu Feb 28, 2019 11:59 am
Well, I'm feeling pretty confident about the changes as they are working fine on all the test files I have been able to find. I'll slipstream later today unless I hear from y'all of any test failures in the meantime.
Late reply, I know but I have some health issues.

I will try on the same BD and tell you ASAP.

Thanks :)

EDIT: tested and works perfectly. On next iteration of parser, please consider chapter extraction too.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] EAC-3 7.1 in m2ts

Post by admin » Mon Mar 04, 2019 8:30 am

OK, thank you. Get well soon.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] EAC-3 7.1 in m2ts

Post by admin » Mon Mar 04, 2019 2:25 pm

I split off the chapter parser thing to a new thread. Please followup there.

viewtopic.php?f=8&t=710

User avatar
tormento
Distinguished Member
Distinguished Member
Posts: 202
Joined: Mon Sep 20, 2010 2:18 pm

Re: [RESOLVED] EAC-3 7.1 in m2ts

Post by tormento » Sat Mar 16, 2019 7:42 am

Just noticed that when demuxing eac3 from mkv, it doesn't append suffix .eac3

Can't remember if it did before or it is a regression.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] EAC-3 7.1 in m2ts

Post by admin » Sat Mar 16, 2019 12:08 pm

It's always been that way. Fix is easy and will be in the next slipstream. Thank you for pointing it out.

Post Reply