[RESOLVED] RTX 2060 is missing from GPU LIST

Support forum for DGDecNV
Post Reply
rooli
Posts: 4
Joined: Tue Mar 26, 2019 3:37 am

[RESOLVED] RTX 2060 is missing from GPU LIST

Post by rooli » Tue Mar 26, 2019 3:48 am

Hello!

I have changed my video card recently for an RTX 2060.
Unfortunately DGDecNV doesn't have this card in the gpus.txt (only 2070 and 2080) so I can't make my card to work with DGDecNV.
I tried to enter the ID (Cuda Code) from the List Video Card window what is: 1F08 but at restart I have an error message.
I have Win10 DCH driver installed instead of WDDM. Can It be a problem? Defauld Cuda device was 255 and using cpu only.

Thanks for your answer.
03Capture.PNG
03Capture.PNG (6.72 KiB) Viewed 425 times
02Capture.PNG
02Capture.PNG (14.27 KiB) Viewed 425 times
01Capture.PNG
01Capture.PNG (8.79 KiB) Viewed 425 times

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: RTX 2060 is missing from GPU LIST

Post by admin » Tue Mar 26, 2019 10:25 am

Being missing from gpus.txt is not a problem. It is only used for display of the video info dialog. I will add it. But you have put a wrong number in the CUDA device field. Read the user manual! Try putting 0 or 255 in there. I don't know what a DCH driver is. I think you must use WDDM.

rooli
Posts: 4
Joined: Tue Mar 26, 2019 3:37 am

Re: RTX 2060 is missing from GPU LIST

Post by rooli » Tue Mar 26, 2019 10:48 am

Thank you for your answer, I'll read the manual.
DCH Driver is a new type of driver that Microsoft wants to use. After 2018 October Update this new type of driver is allowed. This will take over WDDM.

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: RTX 2060 is missing from GPU LIST

Post by admin » Tue Mar 26, 2019 11:49 am

Just put 255 in the CUDA Device field, hit Done, and restart DGIndexNV. After that do you get any errors? If so, what errors?

rooli
Posts: 4
Joined: Tue Mar 26, 2019 3:37 am

Re: RTX 2060 is missing from GPU LIST

Post by rooli » Tue Mar 26, 2019 12:02 pm

When I first launched DGIndexNV I had no errors, the default Device was 255.
During making the .dgi the CPU was working. (I'm not sure if Cuda has to work on this)
I tried to make an avsp script, but the DGDecodeNV.dll was not suitable, because of x32 and x64, so cropping was not available,
so I couldn't try the encoding process yet. I was at work so in the next couple of days I am going to use DGIndexNV -> AVS -> NVENCc64 to encode HEVC.

I have tried ffmpeg with hwaccel nvenc, but the quality was bad, all the videos was blurred out no matter what setting I used.
In lossless mode the picture was great, but 60kbps is a joke.

So as soon as I can make a working script I can tell if it's working for me.

THX!!!!

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: RTX 2060 is missing from GPU LIST

Post by admin » Tue Mar 26, 2019 12:17 pm

rooli wrote:
Tue Mar 26, 2019 12:02 pm
I tried to make an avsp script, but the DGDecodeNV.dll was not suitable, because of x32 and x64, so cropping was not available
Not making much sense here. What was the script and what error did you get? And I don't know what you mean by cropping was not available. Are you using a third-party application?

If you load 32-bit DGDecodeNV then you have to open the script with a 32-bit application. Same for 64 bit. If you load 64-bit DGDecodeNV then you have to open the script with a 64-bit application.

rooli
Posts: 4
Joined: Tue Mar 26, 2019 3:37 am

Re: RTX 2060 is missing from GPU LIST

Post by rooli » Tue Mar 26, 2019 12:28 pm

I have 2 AVSP downloaded. AVSP and AVSPMod. Also an Avisynth rev. 2 (Avisynth+) downloaded from sourceforge.
I tried to use AVSP all the time. Now I tried with 64bit DGIndexNV and AVSPMod and it works perfectly.
I have to set up the cli now for NVENCc64!

User avatar
admin
Site Admin
Posts: 4266
Joined: Thu Sep 09, 2010 3:08 pm

Re: RTX 2060 is missing from GPU LIST

Post by admin » Tue Mar 26, 2019 12:53 pm

OK, great. I'll leave this thread open until I add the 2050 and 2060 to gpus.txt. Thank you for pointing it out.

Post Reply