[RESOLVED] Decoding 420P10 bit file -> only 8 bit in AVS ?

Support forum for DGDecNV
Post Reply
pat357
Posts: 9
Joined: Wed Jan 04, 2012 8:33 pm
Location: Antwerp, BELGIUM
Contact:

[RESOLVED] Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by pat357 » Thu Oct 17, 2019 1:57 pm

Since the "fulldepth" parameter is gone, I noticed that decoding HDR 420P10 files in AviSynth+ always result in a 8 bit decoded stream (YV12).
Is there a way to decode the high bitdepth files in >8 bits depth streams when using Avisynth+ ?

DGSource("D:\film\DXVACheck\3840x2160_HEVC_59.94fps_420P10.dgi) returns a 420P8 (YV12) clip.


When I do the same in Vapoursynth (input HDR 420P10 file) I always get a 420P16 bit stream.

core.dgdecodenv.DGSource(r"d:\film\DXVACheck\3840x2160_HEVC_59.94fps_420P10.dgi) returns a 420P16 clip.

PS
I'm using the latest versions of DGDecNV slipstram 189, Avisynth+ 2772MT and Vapoursynth r47.2.
GTX-1070 TI with 418.91 drivers (not the latest 436.xx)
Windows 10 Pro x64 release 180410-1804

User avatar
Rocky
Posts: 337
Joined: Fri Sep 06, 2019 12:57 pm

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by Rocky » Thu Oct 17, 2019 3:20 pm

Should work fine. Can you please give us a sample?

What are you using to determine the bit-depth of the output?

pat357
Posts: 9
Joined: Wed Jan 04, 2012 8:33 pm
Location: Antwerp, BELGIUM
Contact:

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by pat357 » Thu Oct 17, 2019 4:23 pm

Do you mean that you get P10 or P16 bitdepth as output with P10-P16 bits input files ?
I'll cut a sample and post the link.

For .avs I'm using AVSMeter and FFmpeg (FFplay/FFprobe) to "play" the .avs directly.
Also playing the .avs in MPC-HC (+LAVFilters) reveals the info in the MadVR info screen.

For Vapoursynth, I'm using ClipInfo, "vspipe --info", playing in MPC-HC (+LAVFilters) and FFmpeg.

Are there any better ways/tools to get this info ?

Edit:
link to a dgspit-cutted part :
https://pat357.stackstorage.com/s/P670JTQzXrj9nJu (15 MB)
or
https://pat357.stackstorage.com/s/O7Q8eyxvD4JGCc4 (100 MB)
Last edited by pat357 on Thu Oct 17, 2019 5:17 pm, edited 1 time in total.

User avatar
Rocky
Posts: 337
Joined: Fri Sep 06, 2019 12:57 pm

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by Rocky » Thu Oct 17, 2019 4:56 pm

Thank you, investigating...

For 10-bit or 16-bit DGSource() returns 16-bit. 10-bit streams are padded with 0s to 16-bit.

User avatar
Rocky
Posts: 337
Joined: Fri Sep 06, 2019 12:57 pm

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by Rocky » Thu Oct 17, 2019 5:03 pm

Works fine for me. I just open the script in vdub 2 [DGSource() only] and then do File/Information. It shows P016 color space, which is padded 16-bit as intended.

pat357
Posts: 9
Joined: Wed Jan 04, 2012 8:33 pm
Location: Antwerp, BELGIUM
Contact:

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by pat357 » Thu Oct 17, 2019 5:31 pm

Just tested it using the latest VirtualDUB2 :

Under file-> file information -> Decompressor :
Internal DIB decoder (YV12)

No P016, no high bitdepth.

What NVDIA-drivers are you using ?
Maybe my v418.xx drivers are the culprit ?

pat357
Posts: 9
Joined: Wed Jan 04, 2012 8:33 pm
Location: Antwerp, BELGIUM
Contact:

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by pat357 » Thu Oct 17, 2019 6:00 pm

Got it working !
Apparently there was still a previous version of from the .DLL in my Avisynth auto-load directory : after updating it, everything seems to be ok again !

Thank you for your help and your patience.

User avatar
Rocky
Posts: 337
Joined: Fri Sep 06, 2019 12:57 pm

Re: Decoding 420P10 bit file -> only 8 bit in AVS ?

Post by Rocky » Thu Oct 17, 2019 7:05 pm

Good to hear! Thank you for the updated status.

Post Reply