[RESOLVED] GTX 460 FPB and the PureVideo Deinterlacer

Support forum for DGDecNV
Post Reply
mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

[RESOLVED] GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 12:50 am

It's strange, but it isn't carrying over after you save the project anymore. I had a 9800 GT and it worked then, now it doesn't with that card.

mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 3:54 am

When you use the PureVideo Deinterlacer, it doesn't apply to the video anymore. I did a new installation because I thought that my pc was corrupted somehow, but it's still the same afterwards. The only thing different is the card (from the 9800 GT). It's the GeForce GTX 460 FPB (Free Performance Boost) with 768 MB of GDDR5 ram.

I'm using Windows 7 Home Premium 32-bit. The blue tray icon doesn't show up anymore either.

mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 6:14 am

The blue cuvidserver icon. You know when you use single rate or double rate deinterlacing? It shows that it has been applied to the footage, but now when you save the project, it doesn't keep the applied deinterlacing intact anymore.


LoadPlugin("DGDecodeNV.dll")
video=DGSource("c.dgi")
audio=WAVSource("c.wav")
AudioDub(video,audio)
LanczosResize(720,480)
MSharpen(threshold=10, strength=22, mask=false, highq=true, debug=false)
deblock(quant = 31, aOffset = 1, bOffset = 1)
global MeGUI_darx = 16
global MeGUI_dary = 9
Crop(0, 0, -0, -0)

mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 6:39 am

Yeah, I was able to find out that info, but it isn't working like it was when I was using the 9800 GT. I didn't have to add anything for it when I would apply the settings through the application.

User avatar
admin
Site Admin
Posts: 4382
Joined: Thu Sep 09, 2010 3:08 pm

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by admin » Fri Feb 11, 2011 8:45 am

What version of DGDecNV are you using? Post your full script and describe the exact problem you have.

mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 9:23 am

Hi. I'm using 2038. The problem that I'm having is that the PureVideo Deinterlacing function isn't working with the GTX 460. When I save the project after I apply everything, the deinterlacing doesn't carry over like it did with the 9800 GT, but cropping works, still. I'm using the latest nVIDIA drivers, but even the last 260.99's don't work either. I haven't tried any others.

I've noticed that this specific card has been giving other people a lot problems in games and different other things, too (and me as well), so it could be something with the drivers and this specific card.

LoadPlugin("DGDecodeNV.dll")
video=DGSource("c.dgi")
audio=WAVSource("c.wav")
AudioDub(video,audio)
LanczosResize(720,480)
MSharpen(threshold=10, strength=22, mask=false, highq=true, debug=false)
deblock(quant = 31, aOffset = 1, bOffset = 1)
global MeGUI_darx = 16
global MeGUI_dary = 9
Crop(0, 0, -0, -0)

That's the script I used on the encode that I did, and the one I usually always use with just a few adjustments depending on the resolution. I applied deinterlacing later when I did the encode, though.

User avatar
admin
Site Admin
Posts: 4382
Joined: Thu Sep 09, 2010 3:08 pm

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by admin » Fri Feb 11, 2011 9:27 am

It has nothing to do with the card. With recent versions of DGDecNV the deinterlace settings in DGIndexNV are not carried over. You have to set the correct parameters in the DGSource() call. This is described in the DGDecodeNV users manual. For example:

DGSource("c.dgi",deinterlace=1)

mirogi
Posts: 15
Joined: Sat Dec 18, 2010 3:41 am

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by mirogi » Fri Feb 11, 2011 9:45 am

The last version with the 9800 GT didn't need anything to be added, but with the change of the GPU is when I noticed that it didn't work anymore and it didn't work with the last version in combination with this card either. It's weird though that this card is just acting strange overall and then this starts happening. A confusing situation of occurrences.

User avatar
admin
Site Admin
Posts: 4382
Joined: Thu Sep 09, 2010 3:08 pm

Re: GTX 460 FPB and the PureVideo Deinterlacer

Post by admin » Fri Feb 11, 2011 9:47 am

It's not confusing at all. Your reference to the CUVID server indicates that you must have recently upgraded your version of DGDecNV. That upgrade is the cause of the change you see. As I said, it has nothing at all to do with the card.

Post Reply