[RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Support forum for DGDecNV
gonca
Moose Approved
Posts: 818
Joined: Sun Apr 08, 2012 6:12 pm

Re: Bad delay values for audio demuxed from bluray with a range set

Post by gonca » Thu Jun 21, 2018 5:20 pm

Players are supposed to use PTS to determine the presentation time.
Yes, but players start at the beginning, the issue crops up when using RANGE, i.e. starting somewhere in the middle.
DGIndexNV does it right when demuxing from the start, the issues only show up when using RANGE because studios use some questionable authoring techniques.
Stock clips for studio intros, etc, with missing or mismatched audio, jumping timing stamps etc
Summary
DGIndexNV does it right, the studios are using hacky authoring techniques :salute: :salute: to DGIndexNV and its author

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: Bad delay values for audio demuxed from bluray with a range set

Post by admin » Thu Jun 21, 2018 6:29 pm

I have to keep pointing out that if you do things from the start it is only "correct" if the original file is in sync. Sure that will be true of bluray M2TSs, but not necessarily of arbitrary TSs.

But thanks for the props. ;)

Testing 'forced subs only' demuxing right now, from TS or MKV.

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: Bad delay values for audio demuxed from bluray with a range set

Post by admin » Thu Jun 21, 2018 8:42 pm

Forced subs only working fine!

One more small thing to do then slipstream time.

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: Bad delay values for audio demuxed from bluray with a range set

Post by admin » Thu Jun 21, 2018 8:58 pm

admin wrote:
Wed Jun 20, 2018 6:19 am
ggtop wrote:
Wed Jun 20, 2018 1:41 am
Do you have a (commandline) tool which analyzes those "easy to find" timestamp mismatches? :scratch:
I used to have one but haven't used it in years. Let me see if I can find it. It's possible I had it only on my work computer at the time. I'll post again if I find it.
Sorry, ggtop, I don't have it and I remember it was MPEG2 only in any case.

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: Bad delay values for audio demuxed from bluray with a range set

Post by admin » Fri Jun 22, 2018 11:43 am

Filename DELAY mechanism has been removed in slipstream 149.

gonca
Moose Approved
Posts: 818
Joined: Sun Apr 08, 2012 6:12 pm

Re: [RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Post by gonca » Fri Jun 22, 2018 12:04 pm

Another method that might help get started
Open the mpls with MediaInfo
Use whichever view you prefer
Go to Debug > Advanced
Look for Delay relative to video for the audio track you want
Confirm with eyes and ears

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Post by admin » Fri Jun 22, 2018 12:51 pm

I prefer not to recommend things I have not thoroughly tested. How do we know MediaInfo's heuristic is any good? I'm trying to get away from these dodgy heuristics! Use eyes and ears, as you said.

EDIT: If I mux the streams from your range to MKV without entering a delay, then MediaInfo just reports delay 0. What good is that? Otherwise, it just reports the delay entered into mkvtoolnix.

I don't see why you have suggested this at all.

gonca
Moose Approved
Posts: 818
Joined: Sun Apr 08, 2012 6:12 pm

Re: [RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Post by gonca » Fri Jun 22, 2018 3:52 pm

Just as a start point prior to the eyes and ears

User avatar
admin
Site Admin
Posts: 4408
Joined: Thu Sep 09, 2010 3:08 pm

Re: [RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Post by admin » Sat Jun 23, 2018 12:29 pm

I used trim ts on your stream and then checked it with MediaInfo. It gives a delay that is close to what DGIndexNV used to give, i.e., still a full second off (suggesting that they both use similar heuristics). I just don't consider that a useful starting point. But if you find it useful, I can't argue with that.

gonca
Moose Approved
Posts: 818
Joined: Sun Apr 08, 2012 6:12 pm

Re: [RESOLVED] Bad delay values for audio demuxed from bluray with a range set

Post by gonca » Sat Jun 23, 2018 3:08 pm

If the stream is being trimmed there seems to be no good automated way to determine delay for the audio

Post Reply